Jump to content

Jguy

Retired Staff
  • Content Count

    292
  • Joined

  • Last visited

  • Days Won

    18

Jguy last won the day on April 28 2017

Jguy had the most liked content!

About Jguy

  • Rank
    Advanced Member
  • Birthday 07/16/1987

Contact Methods

  • IRC Nickname
    Jguy

Profile Information

  • Gender
    Male
  • Github
    jguy1987
  • Emulator
    Hercules

Recent Profile Visitors

8391 profile views
  1. Hi Ai4rei I downloaded the full client from rAthena that Akkarin posted over there that I noticed includes your patcher and that works, the patcher opens and works. I notice that it comes with only 4.1.6 so I'll try updating it and see if I have the same issue. Thanks for your attention.
  2. Correct, version 4.2.1.1309 listed as latest on your website. Using 64-bit Tried that version in 32-bit, same issue. Grabbed 4.1.6.1297 and 4.1.5.1292 in both x32 and x64 varieties and still same issue. When you double click on the exe to run it flashes the file explorer window but nothing else happens. No error, no window, nothing. Also have disabled both Malwarebytes and Windows Defender real time protection, no change.
  3. Hi Ai4rei, this immediately crashes on Windows 11. I do not find a log or event viewer entry for the issue. I do have Win 11 Pro that is joined to a domain, if that matters. Plenty of RAM available, and decent CPU. Plenty of Hard drive space on an NVMe. I tried running in compatibility mode for Windows 8 and 7, run as administrator and not. I am running the patcher straight from my kRO base files folder, which I downloaded from the pinned topic by Ridley in this forum. I have a patchRE.inf with the following content: ó Any ideas?
  4. Yes, I meant to post in here to give an update. CodeIgniter 3 is quickly becoming obsolete and I was not able to get it working with PHP7.4, so I'm rebuilding the panel with CodeIgniter 4 with full compatibility for PHP 7.2 and 7.4
  5. Found the issue. Apparently my NAT rules were reflecting my char and map ports back to the login port. Would connect to server and my firewall was trying to send the packet back to the login server.
  6. Log files attached. Can change information later. packet logs.zip
  7. Still no good ./configure make sql make plugin.packetlogger MAKE mt19937ar make[1]: Entering directory '/home/ragnarok/myst/3rdparty/mt19937ar' make[1]: Nothing to be done for 'all'. make[1]: Leaving directory '/home/ragnarok/myst/3rdparty/mt19937ar' MAKE libconfig make[1]: Entering directory '/home/ragnarok/myst/3rdparty/libconfig' make[1]: Nothing to be done for 'all'. make[1]: Leaving directory '/home/ragnarok/myst/3rdparty/libconfig' MAKE common_sql make[1]: Entering directory '/home/ragnarok/myst/src/common' make[1]: Nothing to be done for 'sql'. make[1]: Leaving directory '/home/ragnarok/myst/src/common' MAKE plugin.packetlogger make[1]: Entering directory '/home/ragnarok/myst/src/plugins' PLUGIN packetlogger make[1]: Leaving directory '/home/ragnarok/myst/src/plugins' ./login-server [Info]: Hercules 64-bit for Linux [Info]: SVN revision (src): '27M' [Info]: SVN revision (scripts): 'Unknown' [Info]: OS version: 'Ubuntu 16.04.3 LTS [x86_64]' [Info]: CPU: 'Common KVM processor [1]' [Info]: Compiled with GCC v5.4.0 [Info]: Compile Flags: -g -O2 -pipe -ffast-math -Wall -Wextra -Wno-sign-compare -std=c99 -Wno-unused-parameter -Wno-clobbered -Wempty-body -Wint-conversion -Winit-self -Wpointer-arith -Wswitch-bool -Wformat-security -Wformat -Wformat-signedness -Wformat-y2k -Wsuggest-attribute=noreturn -Wundef -Wnested-externs -Wold-style-definition -Woverlength-strings -Wredundant-decls -Wcast-qual -Wno-format-nonliteral -Wno-switch -Wno-missing-field-initializers -Wno-suggest-attribute=format -Wshadow -fno-strict-aliasing -g -fno-omit-frame-pointer -DHAVE_EXECINFO -DMAXCONN=16384 -I../common -DHAS_TLS -DHAVE_SETRLIMIT -DHAVE_STRNLEN -DDEBUG -DHAVE_MONOTONIC_CLOCK [Info]: Timer Function Type: monotonic clock [Info]: Server uses 'select' as event dispatcher [Info]: Server supports up to '1024' concurrent connections. [Fatal Error]: HPM:plugin_load: failed to retrieve 'plugin_info' for 'plugins/packetlogger.so'!
  8. [Fatal Error]: HPM:plugin_load: failed to retrieve 'plugin_info' for 'plugins/packetlogger.so'! Put the packetlogger.c into /src/plugins added "packetlogger" to /conf/plugins.conf ./configure && make clean && make all run ./login-server and get that.
  9. Revision 3c606f69 Console output: login: [Status]: Connection of the char-server 'Myst' accepted. [Status]: Request for connection of jmanfffreak (ip: 10.10.0.1). [Notice]: Authentication accepted (account: jmanfffreak, id: 2000000, ip: 10.10.0.1) [Status]: Connection of the account 'jmanfffreak' accepted. [Warning]: lclif_parse: Received unsupported packet (packet 0x0065, 17 bytes received), disconnecting session #9. [Info]: Closed connection from '10.10.0.1'. char: [Status]: Map-Server 0 connected: 875 maps, from IP 127.0.0.1 port 10802. [Status]: Map-server 0 loading complete. map: [Status]: Attempting to connect to Char Server. Please wait. [Status]: Connecting to 127.0.0.1:10801 [Status]: Logging in to char server... [Status]: Successfully logged on to Char Server (Connection: '6'). [Status]: Sending maps to char server... [Status]: Event 'OnInterIfInit' executed with '0' NPCs. [Status]: Event 'OnInterIfInitOnce' executed with '0' NPCs. [Status]: Requested '34' guild castles from char-server... [Status]: Map Server is now online. [Info]: Received Fame List of '0' characters. [Status]: Received '34' guild castles from char-server.
  10. Still no luck there. Downloaded, patched with the original NEMO, still same unsupported packet version.
  11. I can cycle through the server select quickly, wait a few seconds, doesn't matter. I tried to change the packet keys and recompiled, still no luck.
  12. Just tried - still same result. Note: 20141022 is what comes by default in Hercules.
  13. Not sure what I'm doing wrong. Trying to get a test server setup. Using 20141022b with ONLY the recommended patches applied via NEMO (Secret's fork) and a basic no frills Translation data folder. mmo.h: #ifndef PACKETVER #define PACKETVER 20141022 #endif // PACKETVER client.conf: // Whether to enable the official packet obfuscation support (good vs WPE) // 0: disabled // 1: optional (not recommended) -- identifies whether it is required // 2: enabled (recommended) packet_obfuscation: 2 Go to login, select my character server and I get a "Disconnected from server" with: [Status]: Request for connection of jguy (ip: 10.10.0.1). [Notice]: Authentication accepted (account: jguy, id: 2000000, ip: 10.10.0.1) [Status]: Connection of the account 'jguy' accepted. [Warning]: lclif_parse: Received unsupported packet (packet 0x0065, 17 bytes received), disconnecting session #9. Any help would be appreciated. Thanks!
  14. Jguy

    Dual Server

    Check out doc/global_configuration.txt.
  15. Indeed - the client cannot handle a larger storage, so sometimes it freaks out and see it as 0/0 and won't load it.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.